导入阿里百川电商SDK的问题

记录一次,由于想做一个导购app,导入SDK的时候,有那么几个总是到不进去,提示: Failed to resolve 😡 xx;

折磨了好久,以为是SDK的问题,换了低版本的sdk可以导入,但是低版本的sdk用的安全图片不是V5版本的,就算导进去了,初始化的时候也会失败。经过错误排查,发现我的是Gradle版本的问题。由于我经常更新Android stdio。所果gradle版本(6.1.1)是最新的,和sdk版本不一致才导致的错误。

解决方法: 更改gradle版本如图1所示。

导入阿里百川电商SDK的问题-发现值得买
图1
//登陆
implementation 'com.ali.auth.sdk:alibabauth_core:2.0.0.6@aar'
implementation 'com.ali.auth.sdk:alibabauth_ui:2.0.0.6@aar'
implementation 'com.ali.auth.sdk:alibabauth_ext:2.0.0.6@aar'
//安全组件
implementation 'com.taobao.android:securityguardaar3:5.4.171@aar'
implementation 'com.taobao.android:securitybodyaar3:5.4.99@aar'
implementation 'com.taobao.android:avmpaar3:5.4.36@aar'
implementation 'com.taobao.android:sgmiddletieraar3:5.4.9@aar'
//Mtop
implementation 'com.taobao.android:mtopsdk_allinone_open:3.1.2.5@jar'
//applink
implementation 'com.alibaba.sdk.android:alibc_link_partner:4.1.15@aar'
//ut
implementation 'com.taobao.android:utdid4all:1.5.2'
implementation 'com.alibaba.mtl:app-monitor-sdk:2.6.4.5_for_bc'
// 电商基础组件
implementation 'com.alibaba.sdk.android:AlibcTradeCommon:4.0.0.8@aar'
implementation 'com.alibaba.sdk.android:AlibcTradeBiz:4.0.0.8@aar'
implementation 'com.alibaba.sdk.android:nb_trade:4.0.0.8@aar'
implementation 'com.alibaba:fastjson:1.2.41'

假如导入上述sdk不全 ,也会出现一系列问题。

本文系作者 @ 原创发布在 发现值得买。未经许可,禁止转载。

喜欢()
评论 (0)

请登录以参与评论。

现在登录…
热门搜索
13 文章
0 评论
6 喜欢
Top